Subscribe Today

Search found 4 matches

Return to advanced search

RX1 PROBLEMS ??????

Update on my RX1. Now have 1900kms on it. It has run perfect until last week. Had done a 300km day. Just made a run down a rail line at about 170kph. We shut down for about five minutes. When I restarted I heard a slight knocking noise which got worse as I rode. Soon it was hammering and I knew it w...
by Vetteman
February 8th, 2003, 1:57 pm
 
Forum: SnowmobileNews Forum
Topic: RX1 PROBLEMS ??????
Replies: 7
Views: 1941

RX 1 ER impressions

Had this sled out twice for a total of 350kms. Here are my impressions:great engine with beautiful sounds and mucho power and torque. comfortable to ride but heavy and it takes a lot of effort to ride in the trails. suspension takes about 250kms to start to loosen up so do not play with it until it ...
by Vetteman
December 23rd, 2002, 10:09 am
 
Forum: SnowmobileNews Forum
Topic: RX 1 ER impressions
Replies: 0
Views: 310

rx-1 break in

The best way to break this thing in is counter to what you might think. Warm it up at idle for about 8 to 10 minutes. Drive it slowly until it is fully warm( about 10 minutes). This should be done everytime you start it cold anyway. For the first 100 kms do not be easy on it as you want the rings to...
by Vetteman
December 23rd, 2002, 9:53 am
 
Forum: SnowmobileNews Forum
Topic: rx-1 break in
Replies: 8
Views: 901

RX1 PROBLEMS ??????

I have had mine out twice this year and put on about 150kms each day. It has been all trail riding and the last ride I ran the machine pretty hard hitting 175kph at one point. The power is great and it sounds beautiful. My buddy has an 800 Legend and I had no trouble keeping up to him in the trails....
by Vetteman
December 23rd, 2002, 9:27 am
 
Forum: SnowmobileNews Forum
Topic: RX1 PROBLEMS ??????
Replies: 7
Views: 1941

Return to advanced search

cron