Subscribe Today

Search found 42 matches

Return to advanced search

Burning Up Belts & Spacing ?

Checked the mounts and they seems fine. The belt rides almost flush on the secondary clutch. There is a plate on the outer edge of the clutch and there are numbers 1-5 and it is at 4. I think that I will try and adjust that so the belt would sit about 1/8 above. The two halves of the clutch are pret...
by XCR600SP
March 10th, 2005, 12:15 am
 
Forum: SnowmobileNews Forum
Topic: Burning Up Belts & Spacing ?
Replies: 5
Views: 678

Burning Up Belts & Spacing ?

Thanks for the info so far. I have double checked the belt part number and it is the right belt. I will try and check the motor mounts tonight. Once again any info is a help.
Thanks
by XCR600SP
March 8th, 2005, 11:56 pm
 
Forum: SnowmobileNews Forum
Topic: Burning Up Belts & Spacing ?
Replies: 5
Views: 678

Burning Up Belts & Spacing ?

I have a 96 XCR 600 SP and have gone through 2 belts in about 1000 miles. Is this normal? Both belts the outside layer comes off. Where should the belt ride in the secondary and what measurements should I check? I put on another new polaris belt on and the track now turns all the time but I have onl...
by XCR600SP
March 8th, 2005, 1:18 am
 
Forum: SnowmobileNews Forum
Topic: Burning Up Belts & Spacing ?
Replies: 5
Views: 678

Choke Removal Question

I have an 96 XCR600SP and the choke cables that all go into the junction block on the dash, how do you get them out of the plastic holder? Once you get it apart all three cables are or appear to be pressed into the plastic. Any info on how to get the cables out would be great.
Thanks
by XCR600SP
March 4th, 2005, 5:09 am
 
Forum: SnowmobileNews Forum
Topic: Choke Removal Question
Replies: 1
Views: 191

Heat Exchanger Protectors?

Thanks for the info. I had a quick look last night and I think that they are riveted on. I will see about tightening them up.
by XCR600SP
February 25th, 2005, 11:51 pm
 
Forum: SnowmobileNews Forum
Topic: Heat Exchanger Protectors?
Replies: 2
Views: 258

Heat Exchanger Protectors?

I have a 96 XCR 600SP and one of the rails under the heat exchanger seems to be loose. How are the rails that mount to the heat exchanger in the tunnel attached? I think that the rails are there to help protect the exchanger from the studs but I am not sure. If anyone knows how to tighten them up th...
by XCR600SP
February 25th, 2005, 12:46 am
 
Forum: SnowmobileNews Forum
Topic: Heat Exchanger Protectors?
Replies: 2
Views: 258

Where can i find a Polaris 600 XC manual and parts???

I am really in need of a service manual or parts manual for a 96 XCR 600 SP. If you have any idea of where I could get something like the one for the 99 600 that would be great. Thanks in advance
by XCR600SP
February 21st, 2005, 11:57 pm
 
Forum: SnowmobileNews Forum
Topic: Where can i find a Polaris 600 XC manual and parts???
Replies: 5
Views: 639

Carb Cleaning Instructions

Ok I have a couple more questions. How do you get the throttle and choke cables out? Do you remove them at the junction block or out of the carbs? Now I am not sure what I have to do to make sure that I don't have to synchronize the carbs. Could you please explain this a little more? Thanks for the ...
by XCR600SP
January 26th, 2005, 2:58 am
 
Forum: SnowmobileNews Forum
Topic: Carb Cleaning Instructions
Replies: 8
Views: 931

Carb Cleaning Instructions

Could someone please outline how to or where to find a detailed description of how to dissasembly and clean a carb on a 96 XCR600SP. I imagine that most carbs are similar so if anyone knows of a good place to get the info that would be great. I am not sure what carbs I have so if someone knows could...
by XCR600SP
January 25th, 2005, 4:42 am
 
Forum: SnowmobileNews Forum
Topic: Carb Cleaning Instructions
Replies: 8
Views: 931

Won't Idle

I rode in some deep snow and had my air breather screen (filter) covered and my polaris 600 would bog right down and hardly run. I cleaned it off and rode home and it worked good. The next day it won't run right. I would start and then won't idle and was hard to keep running. It backfired a couple o...
by XCR600SP
January 24th, 2005, 12:22 am
 
Forum: SnowmobileNews Forum
Topic: Won't Idle
Replies: 2
Views: 239
Next

Return to advanced search

cron