Subscribe Today

Search found 38 matches

Return to advanced search

primer plate for tillotson HD

how are you guys using the primer plates for the HD's? Just hook it up to a bulb and then the gas tank? The opening in the plate is pretty small.I already have one line into the tank im using for the main gas and i would like not to have to drill another one.
by playboy
December 30th, 2005, 12:53 pm
 
Forum: Vintage Sleds Board
Topic: primer plate for tillotson HD
Replies: 4
Views: 222

ski-doo 640 still not starting...

i think its the carb. Anyone got a hd 138a or another hd that has the pulse plate on it.
by playboy
December 7th, 2005, 4:42 pm
 
Forum: Vintage Sleds Board
Topic: ski-doo 640 still not starting...
Replies: 17
Views: 734

ski-doo 640 still not starting...

ttt
by playboy
December 5th, 2005, 1:36 pm
 
Forum: Vintage Sleds Board
Topic: ski-doo 640 still not starting...
Replies: 17
Views: 734

ski-doo 640 still not starting...

yeah i dont really want to get into the ignition because i dont have any experiance with that stuff. But im just thinking im not getting a consistent spark. IT sounds like a fuel problem but i dont know what else could be the problem.
by playboy
December 3rd, 2005, 2:32 pm
 
Forum: Vintage Sleds Board
Topic: ski-doo 640 still not starting...
Replies: 17
Views: 734

ski-doo 640 still not starting...

oh if i end up changing the gap on the points how do i check/re set my timing?
by playboy
December 3rd, 2005, 1:07 pm
 
Forum: Vintage Sleds Board
Topic: ski-doo 640 still not starting...
Replies: 17
Views: 734

ski-doo 640 still not starting...

okay i had some time to check everything out. I guess the HD 138 carb is the one that came for this engine and i had some 14a so i swapped in the 138 and rebuilt it. I sprayed in some gas into the carb and the engine starts for a sec but then the gas burns off and stalls. Im going to look into the p...
by playboy
December 3rd, 2005, 12:59 pm
 
Forum: Vintage Sleds Board
Topic: ski-doo 640 still not starting...
Replies: 17
Views: 734

ski-doo 640 still not starting...

i dont have the motor with me so im not sure about the drain bolts but i will find them and clean out the motor. im mixing 40:1. I believe the plugs are ngk but dont have the number right now. i know they use a 1" socket. i just wanted to see the timing specs to check them and see if they are off. h...
by playboy
November 29th, 2005, 9:45 am
 
Forum: Vintage Sleds Board
Topic: ski-doo 640 still not starting...
Replies: 17
Views: 734

How to time a 1974 ski-doo 640

anyone have the manuel for this sled? or know what verything should be set to?
by playboy
November 29th, 2005, 7:53 am
 
Forum: Vintage Sleds Board
Topic: How to time a 1974 ski-doo 640
Replies: 2
Views: 136

ski-doo 640 still not starting...

the spark looks good but im not sure how consistent it is or if its too weak. I put some wd-40 into the spark plug holes and it didnt start up.
by playboy
November 28th, 2005, 7:20 pm
 
Forum: Vintage Sleds Board
Topic: ski-doo 640 still not starting...
Replies: 17
Views: 734

ski-doo 640 still not starting...

I buddy of mine thinks it might be the points and to replace the condenser. He says the points are too far apart. Im looking on dennis kirk and i cant seem to find the points kit or whatever it is. Would it be called something else? Should i replace the coil too? Do i have an internal or external co...
by playboy
November 28th, 2005, 5:18 pm
 
Forum: Vintage Sleds Board
Topic: ski-doo 640 still not starting...
Replies: 17
Views: 734
Next

Return to advanced search

cron