Subscribe Today

Search found 1170 matches

Return to advanced search

"Random" Spark

Check to see if you knocked anything loose while you were in there and i would go with then ews ones and just regap them.
by jeteralfonso45
August 12th, 2005, 4:31 pm
 
Forum: Vintage Sleds Board
Topic: "Random" Spark
Replies: 2
Views: 439

Things needed:

dennis kirk for the throttle cable they sell universal or just get one for another sled that has a similar length
by jeteralfonso45
July 20th, 2005, 2:57 pm
 
Forum: Vintage Sleds Board
Topic: Things needed:
Replies: 3
Views: 206

arctic cat panther 399 kohler

here are the carb adjustments

http://www.isd.net/ecurtis/carbspecs.htm
Point gaps are usually vary between .014-.025 so try .18 or so
by jeteralfonso45
July 16th, 2005, 4:40 pm
 
Forum: Vintage Sleds Board
Topic: arctic cat panther 399 kohler
Replies: 17
Views: 1556

citation 4500

thank you organized confusion. Good idea on the belt. A telltale sign that your belt is worn to much is that it is glazed over.
by jeteralfonso45
July 16th, 2005, 10:21 am
 
Forum: Vintage Sleds Board
Topic: citation 4500
Replies: 27
Views: 1594

citation 4500

My hunch is the coils or just the fan isn't working first of all if all those seals were bad you would have hard starting, backfiring, bog off the line and the engine would be running lean which = white plugs not golden brown.
by jeteralfonso45
July 15th, 2005, 4:25 pm
 
Forum: Vintage Sleds Board
Topic: citation 4500
Replies: 27
Views: 1594

Star Craft factory mod sled

my bet is that its a starcraft
by jeteralfonso45
July 15th, 2005, 6:35 am
 
Forum: Vintage Sleds Board
Topic: Star Craft factory mod sled
Replies: 6
Views: 371

citation 4500

more likely its because your riding it in to hot of temps its a fan cooled sled and like all engines they loose power when they get really hot. If it isn't something simple like that check the external ignition coils they could be bad
by jeteralfonso45
July 15th, 2005, 6:33 am
 
Forum: Vintage Sleds Board
Topic: citation 4500
Replies: 27
Views: 1594

Post your top speed

thanks rotax power thtas a nice list of sleds you got there
by jeteralfonso45
July 14th, 2005, 2:14 am
 
Forum: Vintage Sleds Board
Topic: Post your top speed
Replies: 81
Views: 12686

problems w/ restored engine

he is correct all kawi's of that era had seal problems if the motor sat for even a couple of years without use the seals would crack
by jeteralfonso45
July 6th, 2005, 12:22 am
 
Forum: Vintage Sleds Board
Topic: problems w/ restored engine
Replies: 8
Views: 508

problems w/ restored engine

backfiring is usually telltale sign that your timing is off. also make sure your firing on both cylinders
by jeteralfonso45
July 1st, 2005, 11:46 am
 
Forum: Vintage Sleds Board
Topic: problems w/ restored engine
Replies: 8
Views: 508
PreviousNext

Return to advanced search

cron