Subscribe Today

600 HO / 600 & 800 SDI Ski-Doo Engines

The general snowmobiling discussion. Discuss snowmobile tech, ask about trail conditions, talk about snowmobiling issues, whatever. Just keep it clean!

600 HO / 600 & 800 SDI Ski-Doo Engines

Postby RabbitEarsRide » November 21st, 2003, 8:33 pm

04's have a new jug part number for 04' and it was the skirt that was cathcing causing the ring flake and pitting. Solved for 04'.
RabbitEarsRide
 
Posts: 1
Joined: November 10th, 2003, 3:04 pm
Location: Grand Junction, CO

600 HO / 600 & 800 SDI Ski-Doo Engines

Postby mlrtym » January 8th, 2004, 7:07 am

I have an MXZ 800 extreme that ha been at the dealer for 3 months as of today with blown crank bearings. This is a known defect and there are 7 other sleds waiting at the dealer for parts.

Ski Doo has been obnoxious to deal with. No effort to make up for this, could care less. Have caled Valcourt and gotten the canned response instead of an extension on my warranty which will run out by the time I get my sled back.

Did I mention the sled has only 590 miles on it?

Ken Miller
MXZ-X #54
Broken 03 MXZ-X #54
mlrtym
 
Joined: January 8th, 2004, 7:07 am
Location: manchester nh usa

600 HO / 600 & 800 SDI Ski-Doo Engines

Postby dave583 » January 8th, 2004, 8:29 am

I heard from several people who had warranty claims on their new ski-doos and ski doo backed all of them. They know about the ring flaking and I heard it has been remedied. It did not happen to all 03's. To me it sounds like a vendor error. Dont be afraid of the doo, best engines in my opinion(reliability).

you want problems get a Cat.
dave583
Member
 
Posts: 16
Joined: November 21st, 2003, 7:56 am
Location: Chicago


Previous

Return to SnowmobileNews Forum

Who is online

Users browsing this forum: No registered users and 5 guests

cron