Subscribe Today

Another Ski-Doo bites the dust!!

The general snowmobiling discussion. Discuss snowmobile tech, ask about trail conditions, talk about snowmobiling issues, whatever. Just keep it clean!

Another Ski-Doo bites the dust!!

Postby DanKam81 » February 26th, 2005, 4:53 pm

alright heres the story, my buddy is a die hard ski-doo fan, bleeds yellow and black, bought a 05 600SDI REV X.. so we were goin out the other day, his 1st ride we left his house rode probably 3 minutes to the gasation and fueled up. got that all done and over with, and were on our merry way, or at least we thought, we got about 27 miles into our ride coming through a long open feild and all of a sudden boom the rev just shuts right down.. lost everything.. so we all come back and see what the problem is, my buddy is standing there kickin his sled swearing ang throwing a fit, with out asking him whats wrong i go over and try to pull it over, and nothing.. completely locked up tight, he says not one idiot light came on or anything just was moving along through the feild and it locked up, so i tow him back to the closest road, and i went back to get my truck and trailer. later that day we took it in the dealer and he was shocked to see us there only 5 hours after pickin it up and he was even more shocked when we told him it was cooked.. so we left it there and didnt hear anything for 4 days, then on the 5th day, my buddy gets a phone call saying that ski-doo just shipped him a new motor and they are putting it in as we speak and the sled will be ready in 3 hours.. wanna know what the whole problem was with the melt down? the person who assemebled it, never hooked up the oil pump!! wasnt even plugged in! makes me wonder about these guys nowadays, there just there to mass produce these sleds and get them out the door ASAP.. my friend has been with this dealer for 13 years and has bought 9 differnt sleds from him in this period, we both came home that night, had a few beers and talked about the whole deal, needless to say he went back the next day and traded that sled in on a 05 F7 sno-pro. 16 years of riding doo and one bad mistake on there part made him jump ship overnight! what can i say at least he is a smart man and went with the only good sled around... a CAT!!
Ride the Cat, Nice and Hard, All night long!!!! '04 F6 sno-pro
DanKam81
Member
 
Posts: 12
Joined: December 2nd, 2003, 1:42 pm
Location: Cowlesville NY

Another Ski-Doo bites the dust!!

Postby SkiDude67 » February 26th, 2005, 6:29 pm

So this was a brand new sled? Why wasn't your buddy running 50:1 premix in the tank for the first two tankfulls like recommended by Ski Doo? Not that this would have avoided the problem....but you would have noticed the oil level wasn't dropping in the oil tank (i.e. not being used) which would alerted you that there was something wrong. This is assuming you check the oil every time you fill up with gas.
SkiDude67
 
Posts: 2
Joined: December 23rd, 2004, 4:16 am
Location: Hobart, IN

Another Ski-Doo bites the dust!!

Postby Johnny Skeptical » February 27th, 2005, 12:19 am

Hmmm, something sounds fishy----the oil tank is low out of the crate but the oil pump comes connected both the drive and cable. He may not have checked for air bubbles in the line but as skidude said the premix is meant to carry it over until the pump bleeds itself for a worst case scenario.
[img]http://pics.greatestjournal.com/userpic/11908820/671512[/img]
BEFORE YAMAHA...
Johnny Skeptical
Member
 
Posts: 11
Joined: October 2nd, 2004, 1:49 pm
Location: Transplanted To The Great White North


Another Ski-Doo bites the dust!!

Postby doo it » February 27th, 2005, 12:22 am

First off, if the oil line wasn't hooked up. The oil would have ran out all over in the pan and at sometime ran out on to the ground I'm sure..

On the second note, you are supposed to run the first couple of tanks of gas mixed 50/1 for break in and too make sure your oiler is working.

So, looks like some of the blame can be on your buddy too!

Thats sure the reason to switch brands.

No matter, I wish him luck for the rest of the year.

Take Care
doo it
Member
 
Posts: 217
Joined: April 11th, 2002, 1:51 pm
Location: frozen hell

Another Ski-Doo bites the dust!!

Postby mxz800rider » February 27th, 2005, 12:33 am

I would say this is more of a dealer problem than a Ski-Doo problem.Im not so sure what u ride my friend but i can guess that you get smoked by the Doo-Man every time u ride. My other guess is it was most likely your mothers other bothers boyfreind that let that sled leave the shop like that.
artic cat sux
mxz800rider
Member
 
Posts: 19
Joined: July 24th, 2003, 11:50 am
Location: HASTINGS, NEW YORK

Another Ski-Doo bites the dust!!

Postby Skiduders » February 27th, 2005, 7:24 am

Even if it wasn't installed properly at production. That should have been noticed during set-up at the dealer. Blame Game is a tough one to play, but if you want to point fingers....there you go.
Skiduders
Member
 
Posts: 30
Joined: December 4th, 2003, 9:57 am
Location: Colorado Springs

Another Ski-Doo bites the dust!!

Postby vwbuggyman » February 27th, 2005, 1:07 pm

The adding oil to the gas for the first 2 tanks is meant to prevent that in worst-carse scenario, the oil pump isn't working. Generally in brand new sleds the injector needs time to fill up and get the air out of the lines, so while this is happening the premix is taking care of the lube. But then again, not hooking up the injector is a major screw-up on skidoo's part.

But why did your friend switch so fast? He got a new engine for free, and the sled would be good as new. I don't think he was as a "die hard" ski-doo fan as you say if he switched to cat's so quickly.
vwbuggyman
Member
 
Posts: 24
Joined: December 12th, 2004, 10:08 am
Location: Troy, NY, USA

Another Ski-Doo bites the dust!!

Postby U.P. Skidoo » February 27th, 2005, 1:22 pm

Your buddy sure the HELL does not bleed yellow and black like you say.......Cant wait to hear what brand he will switch too next week when the F7 has a problem, he will get tired of getting those service bulletins in the mail......anyways hope he enjoys the new sled...............
[img]http://www.freepichosting.com/Thumbs/421591018/1/600/450.jpg[/img][img]http://www.freepichosting.com/Thumbs/421591018/0/200/136.jpg[/img]
U.P. Skidoo
Member
 
Posts: 11
Joined: August 2nd, 2004, 10:48 am
Location: Da U.P. eh


Return to SnowmobileNews Forum

Who is online

Users browsing this forum: No registered users and 6 guests