Page 1 of 1

'95 Polaris RXL Drive train proplems???

PostPosted: February 28th, 2005, 5:55 am
by cbaman16
I have a 95 Polaris RXL 650 tripple and I put about 100 miles on over the weekend and started to have problems. Here's what's happening. As I was riding I notice the sled was acting kind of weird, it felt like the brake was on. I would let off the throttle and I would slow down pretty fast, like I was using the brake a little. Then I would start out again and it took more throttle than normal to get up to speed. The engine sounded right and like it was working well, so I don't think it's that. If I stopped the sled for awhile (5 min) and got back on, it would go away and then come back. Any ideas? Could the takeup cluch be hanging up, or my jackshaft, or gearbox? Bearing?? Any help would be greatly appreciated!!!

Chuck

1995 Polaris RXL 650 fuel injected tripple...

'95 Polaris RXL Drive train proplems???

PostPosted: February 28th, 2005, 7:43 am
by PolarisIndy
Hyfax melting? Next time it does that jump off into some soft snow, see if it goes away. BTW check your hyfax and see if they are shot.

'95 Polaris RXL Drive train proplems???

PostPosted: February 28th, 2005, 11:14 am
by jpiler
The brake might be hanging up or--

Remove the drivebelt ,raise the track off the ground and rotate the whole final drive by hand by turning the secondary clutch.Many times you can locate a final drive problem this way.

'95 Polaris RXL Drive train proplems???

PostPosted: March 1st, 2005, 3:31 pm
by cbaman16
I just replaced the Hyfax because they were shot, and this was the first time out with the new ones. I touched them with my fingers and didn't notice any heat, would I be able to feel it as hot if that was the problem?

'95 Polaris RXL Drive train proplems???

PostPosted: March 1st, 2005, 3:32 pm
by cbaman16
I did check out the brake, but didn't notice any problems with it. I was wondering if it could be a drive bearing or jackshaft bearing going out, so I will try lifting it off the ground and rotating the track by hand.

'95 Polaris RXL Drive train proplems???

PostPosted: March 1st, 2005, 4:00 pm
by RXL-XC7-RIDER
just a guess .... remove the secondary clutch and check the jackshaft bearing.......and brake pads rotor,

let us know how you made out

'95 Polaris RXL Drive train proplems???

PostPosted: March 2nd, 2005, 9:46 am
by indyized
If you just replaced the hyfax and this is your first ride since. I would not sweat it. it is probably just them wearing in and glazing over. Keep it in the soft stuff if you can it will come around. Check you track tension though it may have been to tight or by now the hyfax has worn and the track may be loose.

'95 Polaris RXL Drive train proplems???

PostPosted: March 3rd, 2005, 5:14 am
by cbaman16
Thanks for the help, it sounds more and more like what happened. I am going riding tonight and will keep an eye on it.

Thanks for all the help!!! It was really worrying me.