Subscribe Today

'03 MXZ 600 H.O

The general snowmobiling discussion. Discuss snowmobile tech, ask about trail conditions, talk about snowmobiling issues, whatever. Just keep it clean!

'03 MXZ 600 H.O

Postby whitedust » February 21st, 2007, 12:56 pm

MM700 Yamaha has been blowing me away since 05 RX1. Their 4s sled line up just keeps getting better and better. Slip me some pictures and specs if you come on them. New doo stuff starting to leak out here and there with pictuers same as we saw in December but with model names. Also looks like new clutch arrangement for doo more of top to bottom config instead of inline left to right.
whitedust
Member
 
Posts: 34
Joined: January 23rd, 2005, 8:48 am
Location: Phelps, WI

'03 MXZ 600 H.O

Postby MM700 » February 22nd, 2007, 2:43 pm

Whitedust see Ken lacy post in the trasher section..I posted some "rumored" specs(I got the inside poop from an excellent source who rode one)...and ken posted a tease photo.
MM700
Member
 
Posts: 1555
Joined: October 10th, 2001, 9:20 pm
Location: Northern Wisconsin

'03 MXZ 600 H.O

Postby vwbuggyman » February 22nd, 2007, 5:07 pm

Well, I hope this hasn't come back to bite me in the ass already. See the topic about it backfiring. That would certianly be embarassing, though I can't imagine having the sled on an incline for a few minutes would screw up a cylinder.

I was actually looking at a new Phazer as an alternative to this, I was kinda interested in a 4 stroke machine and didn't want to spend a load on a sled upgrade, and it seemed to fit the bill. But I came here, read about the loads of problems it has, and then I saw this REV anyway that I couldn't pass up.

I'm kinda getting conflicting data here. Some of you are saying to get the rings checked/fixed ASAP. Some say they were already fixed, or performance would already be suffering. If 3k miles is the general consensus, then I won't bother. It would take me 10 years to put 3k miles on a sled, and I'm sure I'll have a nice SDI or a 4 stroke by then.
vwbuggyman
Member
 
Posts: 24
Joined: December 12th, 2004, 10:08 am
Location: Troy, NY, USA


'03 MXZ 600 H.O

Postby MM700 » February 23rd, 2007, 1:10 am

VW......you are making things way more difficult than they have to be...simply take your sled down to your dealer...he can tell you wether that sled has had the ring update done..if it hasn't, they will do it...and you won't have a problem..if it was already done, and you popped a piston...then you will have to open your wallet...it's that simple.
MM700
Member
 
Posts: 1555
Joined: October 10th, 2001, 9:20 pm
Location: Northern Wisconsin

Previous

Return to SnowmobileNews Forum

Who is online

Users browsing this forum: No registered users and 5 guests

cron