Subscribe Today

96 Arctic Cat ZR 580 EFI

The general snowmobiling discussion. Discuss snowmobile tech, ask about trail conditions, talk about snowmobiling issues, whatever. Just keep it clean!

96 Arctic Cat ZR 580 EFI

Postby fastcat » September 16th, 2001, 12:27 pm

My sled is getting about 3 mpg and has no throttle response the compression is 120 psi and has a new coil. I have been told two different things one said that the fuel injectors are bad and the other said the fuel pressure regulator was no good. has anybody had the same problem please help me out!!
fastcat
 
Posts: 2
Joined: September 16th, 2001, 12:19 pm
Location: COTTAGE GROVE MN USA

96 Arctic Cat ZR 580 EFI

Postby Mainecat » September 16th, 2001, 10:26 pm

Check the fuel pressure regulator. But your using way too much gas.
Mainecat
Member
 
Posts: 793
Joined: May 14th, 2001, 10:58 pm
Location: Nice Kitty OUCH!!!

96 Arctic Cat ZR 580 EFI

Postby SKI-DOO KING 800X » September 19th, 2001, 10:57 am

you are using way to much gas if ya think about i instead of wating your money on parts for your zr save your money for a new one buy a 500 sell it the next year and upgrade to a bigger sled and how much gas your buying adds up to a snowmobile in its self almost i got a 2000 mxz 600 and getting the 20002mxzx800 in 2 weeks the mpg is like 16 so think bout new sled its worth it
SKI-DOO KING 800X
Member
 
Posts: 20
Joined: September 19th, 2001, 9:56 am
Location: waiting for those white flakes to start flying



Return to SnowmobileNews Forum

Who is online

Users browsing this forum: Anlusia, Google [Bot] and 6 guests

cron