Subscribe Today

1987 Ski-Doo Escapade - No Power

The general snowmobiling discussion. Discuss snowmobile tech, ask about trail conditions, talk about snowmobiling issues, whatever. Just keep it clean!

1987 Ski-Doo Escapade - No Power

Postby BiggT » January 4th, 2002, 1:20 pm

have a 1987 Ski-doo Escapade 540 cc. It has run great for many years until now. The machine is in great condition. Recently it started to "dog" out. I changed plugs, and removed and cleaned the twin mikuni carbs. Now, I can get the idle fine, but it dogs out while depressing the throttle, then accellerates fine. But when I get on it, it again bogs down under load. Any suggestions or help is appreciated. Thanks.
BiggT
 
Posts: 2
Joined: January 4th, 2002, 1:16 pm
Location: NY

1987 Ski-Doo Escapade - No Power

Postby snodrifter » January 4th, 2002, 2:38 pm

Pull the pilot jets out - clean them out real good-or replace with the same size. I'd guess they are plugged.
snodrifter
Member
 
Posts: 22
Joined: September 12th, 2001, 11:42 am
Location: alexandria, mn

1987 Ski-Doo Escapade - No Power

Postby Indy 500 » January 4th, 2002, 3:10 pm

It might just be the fact its a ski-doo!! lol Just kiddin ya! If its not the pilot jets you might only be running on one cylinder half the time. Lift the rear end up and give her hell till its runnin on both. That might make it kick in.
Jeff
Indy 500
 
Posts: 7
Joined: October 17th, 2001, 1:09 pm
Location: Wisconsin



Return to SnowmobileNews Forum

Who is online

Users browsing this forum: No registered users and 1 guest

cron