Subscribe Today

Another problem...

The name says is all. Got an older sled? Restoring a sled? Discuss your project with other collectors here.

Another problem...

Postby h2onsnow » February 1st, 2006, 3:12 pm

I had an '80 Citation do the same thing, It was 2 problems. One: You said you replaced the wires, Did you replace just the wires and not the coils? I had to replace the coils, because coils will fade at acceleration if they are weak and cause misfiring which inturn would show buildup on the plugs, some times replacing just wires will cause the coils to falter on rpm increase (Ohm to Voltage ratio). I also went through several fuel pumps before finding out that the first pump filled the crankcase with fuel. It takes quit a bit of cranking to empty the crankcase of fuel.Because of no drain in the crankcase, i had to attach a vacuum pump to the fuel pump actuator fitting and slowly turn the motor over for 10 to 20 minutes to vacate the crankcase of fuel. After that she ran perfect. I also ran a 42:1 fuel ratio.
h2onsnow
Member
 
Posts: 14
Joined: January 12th, 2006, 12:07 pm
Location: Pontiac, Michigan

Another problem...

Postby cory49 » February 1st, 2006, 3:28 pm

My engine only has the one coil, with the two wires coming out. I replaced that whole unit last year, as it had a rough start, and would******out after getting hot.

The thing I don't get is that my CDI ignition only lasted 3 years. This upsets me because they aren't cheap, and if I were ever to have a problem like this far away from home concerns me that I will get stranded.
[b]Sledless[/b]
cory49
Member
 
Posts: 110
Joined: November 28th, 2003, 4:36 am
Location: Sudbury, Ontario

Another problem...

Postby h2onsnow » February 2nd, 2006, 2:37 pm

My CDI vibrated alot, so I rubber mounted it further and intalled 2 big braided ground straps. I always carry an extra CDI on the trails, I just search ebay until I find one selling cheap, Its worth the time online. Theres two sections in ebay for sled parts, one in regular ebay, and one in ebay motors.
h2onsnow
Member
 
Posts: 14
Joined: January 12th, 2006, 12:07 pm
Location: Pontiac, Michigan


Previous

Return to Vintage Sleds Board

Who is online

Users browsing this forum: No registered users and 2 guests

cron