Page 1 of 1

670 HO timing problem

PostPosted: January 5th, 2006, 2:06 pm
by froesen
Hi, guys. New to the site, hi to all.

I have a 1999 MXZ 670 HO. I checked the timing as per ski-doo spec the other day, and it was retarded; I verified the timing mark on the flywheel, it was correct, so I adjusted the pickup. Ended up adjusting it to the full-advance position, but it's not enough....timing's still retarded. Any advice/ideas? Thanks.

670 HO timing problem

PostPosted: January 6th, 2006, 3:52 pm
by jpiler
Verify your timing prcedure with a ski-doo mechanic.If thats all good your crankshaft twisted.This can happen easily when you blow a belt at wide open throttle.

670 HO timing problem

PostPosted: January 8th, 2006, 3:16 pm
by Late Braker
I would say that the brass gear that run's the rotory vale is on its way out and if it lets go it will most likely take ur crank with it and then its going to b very pricey to fix...

670 HO timing problem

PostPosted: January 8th, 2006, 3:58 pm
by froesen
as for the crankshaft twist, i figured that checking the timing mark would determine that...so i know that the mag piston and timing mark are clocked correctly. the engine was rebuild last summer, including crank rebuild, which is why i suspected the timing mark first, could have been clocked wrong, but i don't think it is. no belts blown since motor rebuild. as for the timing valve gear, there was no apparent or excessive damage, and i can't see that changing the ignition timing...but i will try to talk to a doo mechanic.

thanks
nik