Subscribe Today

any modded XCR over here?

The general snowmobiling discussion. Discuss snowmobile tech, ask about trail conditions, talk about snowmobiling issues, whatever. Just keep it clean!

any modded XCR over here?

Postby hotseatXCR » November 30th, 2003, 11:46 am

i known what you mean,if you run hot seat pipes with stock timing,midrange really sucks,advance timing 2 degrees and you hit 85 mph at 1/4 throttle or so,it make HUGE difference in the low end torque.those pipes are suited for top end.
hotseatXCR
 
Posts: 2
Joined: October 30th, 2002, 7:42 am
Location: quebec,canada

any modded XCR over here?

Postby #1FASTSLED » December 1st, 2003, 2:52 am

I have an 01 XCR 800 with HTG pipes, heads and V Force III reeds. I'm not sure what gearing is going to be good with this set-up yet, haven't tried it out. But when it was stock I went up one tooth on top thinking it would kinda decrease the track spin from start, I don't think it helped at all. Not sure what I should do.
[i]He who goes to sleep with an itchy butt,
Wakes up with a stinky finger![/i]:B
#1FASTSLED
 
Posts: 4
Joined: September 22nd, 2003, 3:34 am
Location: Chestertown, NY

any modded XCR over here?

Postby hotseatXCR » December 1st, 2003, 3:15 am

from many guys i heard,,there is no cure for the track spinning the XCR is all about,,,put studs or long track kit in it,,,it should help.
hotseatXCR
 
Posts: 2
Joined: October 30th, 2002, 7:42 am
Location: quebec,canada


any modded XCR over here?

Postby polarisguru » December 1st, 2003, 8:09 am

Don't believe for a minute that you can't hookup a 121" 800 XCR. Its all in your setup and suspension setup. Work with your front shock and rear sissors and you can get this sled to hook hard as long as you have your track studded even remotely correct. To many people use the wrong stud, and way to many, and do not get stud penetration. If you are going to race on ice you can't use a trail stud and expect it to hook. I run 192 Woody's Race Carbide pics on mine with a combination of race pics and sharpened trail studs with the angled Woody's Backer and it does not spin.
[img]http://www2.freepichosting.com/Images/421557597/3.jpg height=125 width=150[/img]
polarisguru
Member
 
Posts: 74
Joined: February 6th, 2003, 2:44 am
Location: Indiana

any modded XCR over here?

Postby SLEDHEADRED » December 1st, 2003, 9:13 am

Mine isnt spinning in the grass, it does lift ski's about 6 inches though, then sets them back down at around 100ft.
JOIN A CLUB
[url=http://WWW.DRIFTSKIPPERS.COM]The Driftskippers[/url]
SLEDHEADRED
Member
 
Posts: 1110
Joined: June 3rd, 2001, 11:19 am
Location: Battle Creek Michigan

any modded XCR over here?

Postby foxclick » December 1st, 2003, 9:53 am

would someone help me with the clutching and suspension setup no blocks soft preload limiter bolts tightened up some. should I loosen up the front shock some and get more track on the ground?
foxclick
Member
 
Posts: 22
Joined: October 6th, 2003, 11:31 pm
Location: rome ny

any modded XCR over here?

Postby hotseatXCR » December 2nd, 2003, 9:03 am

polarisguru,what is your clutching no?
i must spin it at 8500 rpm no more,have a hot seat 38x (50/38) helix in it right now.
hotseatXCR
 
Posts: 2
Joined: October 30th, 2002, 7:42 am
Location: quebec,canada

any modded XCR over here?

Postby White Lighting » December 2nd, 2003, 2:13 pm

Since you guys are talking about triples I figured you could answer this question for me. Was there ever a performancs SINGLE pipe for a 95 XLT? I heard someone say that they had one, but didnt think it was true. Thanks.
GET ER DONE!!!
White Lighting
 
Posts: 3
Joined: November 13th, 2003, 1:48 pm
Location: New York

Previous

Return to SnowmobileNews Forum

Who is online

Users browsing this forum: No registered users and 2 guests