Subscribe Today

2003 F-7 Problems

Want to bash brands? Go ahead on this board. Profanity, personal attacks or sexual references will not be tolerated and will be deleted.

2003 F-7 Problems

Postby PolarisIsBetter » January 15th, 2004, 7:13 pm

no doubt cat sucks, but better thab the 800 lb japanaha import cocksuckin sleds
Polaris Rules, and your sled sucks.
PolarisIsBetter
 
Posts: 2
Joined: January 15th, 2004, 5:08 pm
Location: Polaris

2003 F-7 Problems

Postby FreezurBurnt » January 16th, 2004, 2:35 am

RWL?:R

zrcat?:R

Mainecat?:R

Care to reply:B
[b]ride Chelmsford,Northern Ont. area[/b]

[img]http://www.s-seriesforum.com/forum/images/smilies/bowdown.gif[/img][img]https://www.snowgoer.com/SharedContent/cfb/memberphotos/3793/rig/my%20truck%20driver%20side%20neg.jpg[/img]
[green][b][i]01 ZR 600 early release[/b][/i][/green]
FreezurBurnt
Member
 
Posts: 489
Joined: May 29th, 2001, 2:00 am
Location: Polaris....my choice in Telescopes!!!

2003 F-7 Problems

Postby The Borg » January 16th, 2004, 3:00 am

You guys have perfect timing...a friend working at another company just called and had one of those 'you gotta hear this' stories...
A coworker who has a camp on Tug Hill, last year had an F5. He had some issues with it, so figured an F6 this year would be better. Last night, before the weekend ride tomorrow, he found all his rivets loose and coming out, in the back of the tunnel. His rear suspension is literally falling out. He has ridden the F6 3 times. He brought it to the local dealer, and the dealer told him he rides too hard, and needs his shocks revalved.
This is not a joke..my bud offered him his 01 Machz to use for the weekend. I told him to loan him one of my RX's...to add insult to injury...
Anyone heard this one before? Or can this one be explained away?
Maybe he rides harder than those racer guys that developed these sleds? Need to know. Get too many conflicting stories about race proven stuff being so much better. LOL.
:B
[COLOR=#0000ff]Welcome to.........The Real World. :p[/COLOR]
[img]http://img72.imageshack.us/img72/2103/pc1600246vg.jpg height=200 width=280[/img]

[url=http://cavecountryriders.com]http://cavecountryriders.com[/url]
The Borg
Member
 
Posts: 121
Joined: September 18th, 2003, 10:36 am
Location: AC tour:'.next, design. Then it's all downhill'


2003 F-7 Problems

Postby The Borg » January 16th, 2004, 3:11 am

And this is the proper address for Cat:


Arctic Enterprises
1 Pieceajunka Lane
Island of Itzzapieceacrappa
12218-84383 Country of Itzzalottascrappa
[COLOR=#0000ff]Welcome to.........The Real World. :p[/COLOR]
[img]http://img72.imageshack.us/img72/2103/pc1600246vg.jpg height=200 width=280[/img]

[url=http://cavecountryriders.com]http://cavecountryriders.com[/url]
The Borg
Member
 
Posts: 121
Joined: September 18th, 2003, 10:36 am
Location: AC tour:'.next, design. Then it's all downhill'

2003 F-7 Problems

Postby Mainecat » January 16th, 2004, 4:52 am

Sorry no answer from me MM to someone who's first post on a trasher site is lookin for answers to problems. Its just BS. If he really wanted help he would have posted on the other page or another site. HCS is tossing these guys left and right. TY did it too. Its pure BS
Mainecat
Member
 
Posts: 793
Joined: May 14th, 2001, 10:58 pm
Location: Nice Kitty OUCH!!!

2003 F-7 Problems

Postby raisinL » January 16th, 2004, 5:12 am

MK thou this story may be BS. I ride with 3 F7s 2 last year cracked their bulkheads. So this is no joke. The other guy had no problems with his till 2 days ago he went to go start it with 320 miles on it and the pull cord broke. He must have not got that update. With 10 guys waiting to ride and you in the middle of the woods. I wouldnt of wanted to be in his shoes.
raisinL
Member
 
Posts: 319
Joined: October 15th, 2003, 3:52 pm
Location: Yamaha The most talked about snowmoible on the net

2003 F-7 Problems

Postby racinfarmer » January 16th, 2004, 9:44 am

Alright, I'll give my useless opinions, as usual, again. I would like to speak up on the side of the F7. My dad has a 03 F7 Patriot Edition w/Sno-Pro package. He bought itm a week later, hauled it in for all the updates, and have never had a problem since then, 3400 miles later. Myself, I would say it is your dealer not caring about they customers. Find a different one. You got screwed. The three different dealers we buy from have always had top notch service. If you want to know who they are, PM me.

Later
This space left blank in memory of Animal, Doug, and every other snowmobiler who has lost their life participating in the sport they love.
racinfarmer
Member
 
Posts: 58
Joined: November 24th, 2003, 11:23 am
Location: Utah

2003 F-7 Problems

Postby ROGER C. » February 5th, 2004, 8:41 am

A friend of mine bought a 2003 fz used of a lots in Merrickville Ont.
1500 miles on it, sales man said it was to fast for the previous owner.
No problems with the sled at all, he said. What a B.****ter, he turned out to be.
Well after finally getting enough snow to try it on, it lasted a grand total of 200 miles and fried the motor. He had noticed it was running hot the week b4, took it back to the same dealer, he said he fixed. He did all right but I don't classify unhooking the temp gauge as a fix. So the next weekend when he had it out the light wasn't hooked up and guess what it fried.
Nice guy at the dealer to help out with light.
Went back to the dealer, he had all sorts of idea's snow built up and could get cool. Snow built up by towing off the trail.
Finally got ahold of previous owner, he tells me it was blown up in the first 1500 milesa also.
Well I have had my fill of these tell you anything dealers.
I have been doing alot of reading and they say that the 2003 had an over heating problem, causing 2 motor to fry in under 2000 miles.
Is this a common problem with the f7? Is there anyway of getting support threw cat? The dealer I wouldn't believe even if I could see what he was talking about.
Not very happy with the f7 or the dealer in Merricksville Ont.
ROGER C.
 
Posts: 6
Joined: January 20th, 2004, 7:32 am
Location: ATHENS , ONT.

2003 F-7 Problems

Postby RWL » February 5th, 2004, 8:49 am

2,450 miles on mine & I have had the same D*A*M*N Problem since day 1 aswell...Ive brought it back to the dealer once to get the updates all done & It came back the same way...can't seem to get rid of the problem which is FINDING A SLED THAT WILL BEAT THIS ONE! not speed wise & (so far)not reliabilty wise!......P.S sorry to hear about your sled!(if only there was never a bad apple in a bunch)...RIDE-ON:B
"on a still summer's night you can hear the ring's flake in a rotax engine" :o
RWL
Member
 
Posts: 130
Joined: September 25th, 2003, 7:38 am
Location: "I own a fleet 4" SO THERE!!!!!!!!

2003 F-7 Problems

Postby RWL » February 5th, 2004, 9:00 am

ROGER C, NEVER BUY A USED PERFORMANCE SLED!(thought everybody knew that) You have no friggin idea what it's gone through,here's a heads up MOST 03'f-7 owners that purchased new & had ALL the updates done & performed regular maintnance have not had any REAL problems!..The REAL problems w/these are the cowboys that are starting them & going WOT! most of the REAL problems are a result of kids used of owning a sled with straight handle bars(bent tip handle bars are for perfomance sleds if ya didnt know) that are designed to pull cord jump on & go.........reallly is pitiful.......P.S KEN you post this on a trasher board then ask "please no this sled suc ks responses?????? GEE O.K........
"on a still summer's night you can hear the ring's flake in a rotax engine" :o
RWL
Member
 
Posts: 130
Joined: September 25th, 2003, 7:38 am
Location: "I own a fleet 4" SO THERE!!!!!!!!

PreviousNext

Return to Trash Talkers

Who is online

Users browsing this forum: No registered users and 4 guests

cron