Subscribe Today

1999 Formula Z 500 electrical problems

The name says is all. Got an older sled? Restoring a sled? Discuss your project with other collectors here.

1999 Formula Z 500 electrical problems

Postby PeteA34 » February 29th, 2004, 11:23 am

The sled will at times have good spark, then weak spark and now I have no spark. I have disconnected the tether switch, the kill switch, and the ignition module. I changed coils. I also swapped CDI boxes out with a known good one. I had the sled at the dealer they replaced the pick up coil and supposedly tried a different stator. I am not 100% sure they actually did since I personally did not see it happen. I have tried new plugs. I also unplugged all the harnesses to see if any were loose or not tight. Everything looked good. I give up, anyone have any ideas of what might be wrong? I called another dealer and they said that particular sled had a wire problem under the engine that caused the symptons I am having. They said I would have to pull the engine to fix this. I don't see a wire that goes way under the engine, at least one thats not accessible. Anyone heard of this before?
PeteA34
 
Posts: 2
Joined: February 29th, 2004, 11:13 am
Location: Shakopee, MN

Return to Vintage Sleds Board

Who is online

Users browsing this forum: No registered users and 2 guests

cron