Subscribe Today

why

The name says is all. Got an older sled? Restoring a sled? Discuss your project with other collectors here.

why

Postby yamaha440 » September 13th, 2006, 1:25 pm

on my citation every time i put a new light in the front and the speedometer within 3 seconds it will blow and in the rear the light bairly lights up at all the only way to et the light to come on is to give it over half throttle any ideas ow i also wanted to now if you can still get the stickers for it if so where emd how much
thanks
yamaha440
Member
 
Posts: 43
Joined: February 25th, 2006, 1:36 am
Location: owen sound ontario

why

Postby JBGabriel » September 13th, 2006, 2:36 pm

Sounds like your voltage regulator is gone. As for the stickers I dont't know for sure but I have seen decal kits go on e-bay. They are pretty expensive though.
Jed

1971 Ski-doo Olympique 300
1980 Kawasaki Drifter 440 in a Honda Odyssey frame
JBGabriel
Member
 
Posts: 12
Joined: February 24th, 2005, 4:20 pm
Location: Buffalo, New York

why

Postby mrbodyman21 » September 13th, 2006, 7:04 pm

try a diffrerent bulb, check the volt reg, make sure connections are all secure
mrbodyman21
Member
 
Posts: 23
Joined: September 6th, 2006, 3:51 am
Location: Michigan


why

Postby Snojet Steve » September 14th, 2006, 8:12 am

[url]http://www.skidoodecals.afegraphics.com[/url]
Snojet Steve
Member
 
Posts: 123
Joined: November 18th, 2003, 2:58 pm
Location: By the sea and amongst the hills

why

Postby ZR800XC » September 14th, 2006, 1:32 pm

Make sure that the wire going to the rear light isn't worn through and grounding against the tunnel. And yes, the voltage regulator sounds like it's FUBAR.

[url=www.sledstuff.com]Make sure and check out decals at sledstuff.com![/url]
They have really nice stuff


[img]http://my.core.com/~twister76/twister1.jpg">[/img]

ZR800XC
Member
 
Posts: 23
Joined: December 20th, 2001, 12:18 pm
Location: Michigan


Return to Vintage Sleds Board

Who is online

Users browsing this forum: No registered users and 1 guest

cron