Subscribe Today

Yamaha prestige

The name says is all. Got an older sled? Restoring a sled? Discuss your project with other collectors here.

Yamaha prestige

Postby KURT WOLF » February 2nd, 2006, 12:57 pm

Just picked up a 76 yamaha prestige with hydrualic automatic drive. Took it to a great Yamaha guy nearby and he said the drive system is junk. Need to know if anyone knows where I could find parts or a parts sled.
KURT WOLF
 
Posts: 5
Joined: December 20th, 2005, 1:49 pm
Location: Oconto Falls, WI

Yamaha prestige

Postby Maniac998 » February 3rd, 2006, 2:58 am

I don't have an answer for you, but I'm definately interested in the results, as I to have just picked up an '74 TW433 with hydro-drive. And from my understanding, has the same problems as yours. So, how-about it gentleman. Any help out there?

Maniac:B
Maniac998
 
Posts: 3
Joined: December 4th, 2005, 1:58 pm
Location: Brantingham, NY

Yamaha prestige

Postby HYDRAULICYAM » February 3rd, 2006, 10:16 am

I have been looking for a 76 Prestige for my collection.
What seems to be the problem with the drive ?? I have 17
of these drives from most years in 11 chassis of which 6
will run if I spend a bit of time persuading them .......
Only my TW433 has ever leaked , and even though I have had
my 74 TL433 since new and pull a groomer sometimes , it has never
failed me , maybe just overflow a bit of dextron if worked to hot.
some of my machines can be seen on gallery of www.acscc.com
I am near Toronto On. and will help to best of my knowledge.
Ron
Collecting Yamaha Hydraulic Drive Sleds
EW643 , TL433 , TW433 , PR440
From 1972 --1977
HYDRAULICYAM
 
Joined: June 23rd, 2004, 10:39 am
Location: Stouffville , Ont.,Canada


Yamaha prestige

Postby duncn70 » February 3rd, 2006, 3:11 pm

Didn't Arctic Cat make a Hydralic Drive sled? The Arctic Cat V.I.P. Panther which was like the deluxe edition Panters. I've heard that they had a lot of torque and haven't heard of them breaking like that but they are pretty rare so maybe they did. -Mike.
[b]Sleds I own:[/b]

[ul][*]1977 Yamaha GS 340 (mint for sale)[*]1973 Ski doo TNT Silver Bullet 340[*]1976 Rupp Nitro 440 L/C[*]1979 Yamaha SRX 440
[/ul]


[COLOR=#ff3300]IF IT DOESN'T GO [b]BAAAAAAAAAAAAAAAAAAAAAAP[/b] IT'S JUST A TRAIL SLED!!![/COLOR]

[COLOR=#0000ff]Check out the T-Jets.[/COLOR]
duncn70
 
Posts: 5
Joined: January 1st, 2006, 2:56 pm
Location: Southeast, WI

Yamaha prestige

Postby Maniac998 » February 3rd, 2006, 6:18 pm

Hydraulicyam, Thanks! It sounds like you've got a great collection started! Once I pick up my TW433 and find out exactly whats wrong with the drive, I'll probably be back to pick your brain. That's what makes this site so useful. All kinds of knowledgeble, helpful people on it! Thanks. Maniac:B
Maniac998
 
Posts: 3
Joined: December 4th, 2005, 1:58 pm
Location: Brantingham, NY

Yamaha prestige

Postby HYDRAULICYAM » February 6th, 2006, 5:29 am

Hi Maniac
My TW433 came from Stowe, Vermont area .and was at AL's in
Magog Lake area orig....Unless it just scorched oil , I have
tech books at home . there is a ring inside taht allows the unit
to "coast" and therefore ,it wouldn't work if turned backwards
or if the ring is broken ....the chain case parts should be the
same as a wide track belt drive , except the top shaft ...
...The VIP cats with hydraulic drive had no belt .the conv .
was in the chain case and directly bolted to the engine .
2 diff stories ...they would fail a gasket or seal , lose the
oil onto the ground as you drove , and implode. Or just like
new as they didn't have a neutral to help get started on the
really cold day , and ended up with less mileage on them .
Good luck .....Ron
Collecting Yamaha Hydraulic Drive Sleds
EW643 , TL433 , TW433 , PR440
From 1972 --1977
HYDRAULICYAM
 
Joined: June 23rd, 2004, 10:39 am
Location: Stouffville , Ont.,Canada

Yamaha prestige

Postby Maniac998 » February 7th, 2006, 12:58 am

Thanks Ron! I can't wait until this weekend. That's when I get to see my new baby! (TW433)
Maniac:B
Maniac998
 
Posts: 3
Joined: December 4th, 2005, 1:58 pm
Location: Brantingham, NY

Yamaha prestige

Postby KURT WOLF » February 7th, 2006, 1:29 pm

Thanks for all the info. I have to go see the guy who has the sled now and have him show me exactly whats wrong instead of "the drive system is junk, you need a new one. At least I know there's someone out there that knows about these things. Thank god for the internet!!!
KURT WOLF
 
Posts: 5
Joined: December 20th, 2005, 1:49 pm
Location: Oconto Falls, WI

Yamaha prestige

Postby HYDRAULICYAM » February 8th, 2006, 10:29 am

I do have some of the supplementary tech books for the PR440 ,
might be a 77 but same in concept , might have narrower rad .
back in Dec a couple of guys responded from WI that may have
units to sell ....I'll look back on the forms and see if I can
find their names ...
RON
Collecting Yamaha Hydraulic Drive Sleds
EW643 , TL433 , TW433 , PR440
From 1972 --1977
HYDRAULICYAM
 
Joined: June 23rd, 2004, 10:39 am
Location: Stouffville , Ont.,Canada

Yamaha prestige

Postby KURT WOLF » February 8th, 2006, 1:22 pm

I got this one in early jan. from a guy not too far from me, I know he had posted it on IRONDOGS and someone from Canada had been interested in it, but they were unable to make connections or something, anyway i got it pretty reasonable and couldn't pass it up.
KURT WOLF
 
Posts: 5
Joined: December 20th, 2005, 1:49 pm
Location: Oconto Falls, WI

Next

Return to Vintage Sleds Board

Who is online

Users browsing this forum: No registered users and 1 guest