Subscribe Today

Ski doo - starts and runs then loses power and dies

If you're looking for advice or if you have a tuning tip for your fellow snowmobilers, this is the board for you.

Ski doo - starts and runs then loses power and dies

Postby 1997mach1 » February 10th, 2006, 4:04 pm

I got a 1997 mach 1. I just had a new engine put in and V-Force Reeds, it ran fine for about 200 miles now when I start it it runs fine for ~10 minutes then it seems to lose power and shuts its self off. After waiting a while it will start back up and do the same thing again. Any suggestions on WTF is wrong?
1997mach1
 
Posts: 1
Joined: February 10th, 2006, 3:51 pm
Location: northeast ohio

Ski doo - starts and runs then loses power and dies

Postby northern_sled_freak_69 » February 10th, 2006, 6:02 pm

broken reeds?
go big or go home......missing the snow and side hilling with my truck
northern_sled_freak_69
Member
 
Posts: 17
Joined: November 14th, 2001, 10:47 pm
Location: hay river nwt canada

Ski doo - starts and runs then loses power and dies

Postby jammo » February 13th, 2006, 2:02 am

Possibly vapor lock. Something is not allowing your fuel tank to vent properly
jammo
 
Posts: 1
Joined: February 12th, 2006, 10:15 am
Location: ontario


Ski doo - starts and runs then loses power and dies

Postby snoguy14 » February 13th, 2006, 3:42 pm

Oh where to start.What do the plugs look like?Was the engine rebuilt by a pro or a shadetree.Does your fuel pump seem to pump enough fuel? Check the coil for a crack i have seen a coil get hot and discharge getting the same symptoms when the motor cools.Is the cdi failing? PLUG colour is the most important info are they wet when it stalls?Try this run the sled,wait for the failure pull the plugs if their wet i'd bet on ignition failure if they are very light check fuel delivery it could be as stated a simple problem with the vent hose,or a clogged pulse line,it could even be the wiring getting warm and grounding don't laugh i've seen all the above happen.
I'm not fast, your just slow.
snoguy14
Member
 
Posts: 63
Joined: August 15th, 2001, 5:12 am
Location: sutton ontario canada


Return to Tech Talk

Who is online

Users browsing this forum: No registered users and 0 guests

cron